InDashPC.org Forum Index InDashPC.org
In Dash Car PC forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

USB Adapter issues
Goto page 1, 2, 3, 4, 5, 6, 7  Next
 
Post new topic   Reply to topic    InDashPC.org Forum Index -> Car integration
View previous topic :: View next topic  
Author Message
zee
Newbie


Joined: 24 May 2009
Posts: 24

PostPosted: Wed Jun 03, 2009 8:04 am    Post subject: USB Adapter issues Reply with quote

I purchased the USB adapter with trunk installation option for a BMW 2004 M3 with Nav.

The adapter works and I can hear music. I have applied the latest firmware as suggested on gromaudio website.

I have already submitted multiple tech support requests and called the phone number without much luck. I still have a little bit of patience before I return the unit if someone listens to me.

I have below issues and I expect some answers/comments about each one:


1- The USB adapter sometimes freezes and music stop playing.

2- For no reason the mode changes from CD changer to radio and sometimes it won't let me select CD changer mode back.

3- The scan feature to skip 10 tracks does not work. I choose scan by pressing on Sel button, and then hit next, only next track plays instead of skipping 10 tracks.

4- If I fast forward, the USB adapter software crashes, sometimes it'll fast forward for few seconds and then gets stuck fast forwarding. I have to unplug the cable from USB adapter to reset it.

5- When CD changer mode is selected I cannot input directions to GPS because USB adapter has control of the screen. I would expect the USB adapter software not to interfere with GPS.

6- There is no way of knowing of current firmware version to know if update process worked or not.

7- The USB thumb drive light is always on even when the car is turned off (without a key in ignition). Should not the adapter be shut off when the car is off? This would drain the battery.

To me this seems like buggy software. The hardware seems to be working fine but I might be wrong.

I'm a software engineer and can get technical.


Last edited by zee on Wed Jun 03, 2009 9:14 am; edited 1 time in total
Back to top
View user's profile Send private message
jbors
Site Admin


Joined: 12 Nov 2004
Posts: 1675

PostPosted: Wed Jun 03, 2009 8:35 am    Post subject: Reply with quote

Did you update to the latest firmware version ?
Back to top
View user's profile Send private message
Stanislav
Newbie


Joined: 25 May 2009
Posts: 15

PostPosted: Wed Jun 03, 2009 9:00 am    Post subject: Reply with quote

+1 to zee
all same problems + volume too high (sound distorted) + if i reconnect flash there is 95% chance that it will not work...and i will have to disconnect\connct again adapter to car + it only works with my very old 256 flash.... tryed 2 new ( 2 and 4 GB) -didn't worked...tryed fat 16\32..no luck.
(256mb falsh that comes with adapter also not working..funny eh(and yes...if i connect 2\4GB or 256mb that comes with adapter to PC they all work perfecly..) ?)


Last edited by Stanislav on Wed Jun 03, 2009 10:48 am; edited 1 time in total
Back to top
View user's profile Send private message
zee
Newbie


Joined: 24 May 2009
Posts: 24

PostPosted: Wed Jun 03, 2009 9:10 am    Post subject: Reply with quote

I updated the firmware with gromusb2_bmw_8.hex file. downloaded from software section from gromaudio site.

http://www.gromaudio.com/downloads/firmware/gromusb2_bmw_8.hex

I followed the instructions. The USB thumb drive light did not turn off as the instructions say, it simply blinked for a fraction of a second and then the light stayed on. I can see song file names displayed better on screen after updating the firmware. But still there is no way to know the current firmware running on USB adapter.


Last edited by zee on Wed Jun 03, 2009 9:12 am; edited 1 time in total
Back to top
View user's profile Send private message
zee
Newbie


Joined: 24 May 2009
Posts: 24

PostPosted: Wed Jun 03, 2009 9:11 am    Post subject: Reply with quote

Just to clarify I used three different USB thumb drives sizes to apply the firmware (yes I applied the firmware update three times just to be sure). 256MB, 2GB, and 8GB. I can hear music from all these thumb drives.
Back to top
View user's profile Send private message
jbors
Site Admin


Joined: 12 Nov 2004
Posts: 1675

PostPosted: Wed Jun 03, 2009 3:20 pm    Post subject: Reply with quote

Some clarifications:
On some stereos including Navi SCAN function will not work unless the track is advanced by itself.
Try latest version 9.
Back to top
View user's profile Send private message
jbors
Site Admin


Joined: 12 Nov 2004
Posts: 1675

PostPosted: Wed Jun 03, 2009 3:21 pm    Post subject: Reply with quote

Stanislav wrote:
+1 to zee
all same problems + volume too high (sound distorted)
What stereo do you have ? Is it Silver box or plastic one ?
Volume issue on all tracks or some ?
Back to top
View user's profile Send private message
zee
Newbie


Joined: 24 May 2009
Posts: 24

PostPosted: Wed Jun 03, 2009 7:23 pm    Post subject: Reply with quote

I tried latest version 9. The issue where the CD changer mode switching by itself to radio happened again.

The USB thump drive light is still on when car is off.

I can see the AUX mode.

The dial on right side does not advance tracks, which used to conflict with GPS screen. However, when CD changer mode is selected I cannot select GPS screen, once GPS screen has focus USB adapter switches back to show song name.

When fast forwarding, it keeps going it does not stop. I had to reset the USB adapter to get out of it.

Pretty much all of the issues I mentioned before still exists except that I see the new AUX mode.

Is there going to be another update to fix those issues?

Is it possible to have access to the source code of firmware? I could help to resolve these issues. I'm a little familiar with i-Bus interface protocol. I suggest you consider making the firmware open source and have people help stabilizing the software and get it tested better.

jbors wrote:
Some clarifications:
On some stereos including Navi SCAN function will not work unless the track is advanced by itself.
Try latest version 9.
Back to top
View user's profile Send private message
Stanislav
Newbie


Joined: 25 May 2009
Posts: 15

PostPosted: Thu Jun 04, 2009 2:04 am    Post subject: Reply with quote

jbors wrote:
Stanislav wrote:
+1 to zee
all same problems + volume too high (sound distorted)
What stereo do you have ? Is it Silver box or plastic one ?
Volume issue on all tracks or some ?


bmw navi(MK4) with 16:9 screen(cassete behinde screen), with 6-cd changer in trunk.

silver box, volume too high(i can cleary hear distortion, even on low volumes...bass is just terrible because fo this.. i think its codec issue in GROM adapter...volume is too high in software) on 98% tracks...most of them are converted to mp3(320 kb\sec) with LAME mp3 encoder from FLAC (without any nomralization etc..)

updated to ver9, can see AUX mode, didn't tryed to play any audio yet

but it keeps switching to cd screen all the time..like in ver 8...


btw...i think we have same audio systems with zee...


Quote:
Is it possible to have access to the source code of firmware? I could help to resolve these issues. I'm a little familiar with i-Bus interface protocol. I suggest you consider making the firmware open source and have people help stabilizing the software and get it tested better.

+1...
Back to top
View user's profile Send private message
jbors
Site Admin


Joined: 12 Nov 2004
Posts: 1675

PostPosted: Thu Jun 04, 2009 6:46 am    Post subject: Reply with quote

zee wrote:
I tried latest version 9. The issue where the CD changer mode switching by itself to radio happened again.
Does it happen anytime within song ?
zee wrote:
The USB thump drive light is still on when car is off.
It will turn off in 1-2 minutes, please check that.
zee wrote:
When fast forwarding, it keeps going it does not stop. I had to reset the USB adapter to get out of it.
Which Navi you have ? III or IV ?
Back to top
View user's profile Send private message
zee
Newbie


Joined: 24 May 2009
Posts: 24

PostPosted: Thu Jun 04, 2009 9:15 am    Post subject: Reply with quote

jbors wrote:
Does it happen anytime within song ?

Yes, any song would be playing and suddenly the radio mode is activated, I have to wait for few minutes until I can select CD changer mode again.

zee wrote:
Which Navi you have ? III or IV ?


It's IV. The number on it is BMW NRR200-02 if that matters. The unit is a 2004/2005 one and uses 2005 DVD navteq maps.

Any comments about the fast forwarding issue?
Back to top
View user's profile Send private message
Stanislav
Newbie


Joined: 25 May 2009
Posts: 15

PostPosted: Thu Jun 04, 2009 11:30 am    Post subject: Reply with quote

zee you can try to turn right knob on navi and press few times next\prev track while in radio mode, after that press mode button and adapter will play again..you don't have to wait 2-3 mins (but still...this is a "bug").


I have tested ver9 a bit, and found 1 more bug...now adapter saying "USB" all the time i'm pressing next\prev track(don't know if it will say that when its going to next track without button press yet)...very annoying. As i can see there is no any bug's fixed...only new bugs, seriously thinking about getting my money back now, my friends who have dension 300 don't have any of this problems.

p.s. there is like 10 ppl waiting for testing results(from e46club.ru forum)...and what can i say to all thos people ?


p.p.s.
Quote:
It can be done but we can try to adjust codec volume first....
will be back next week, Please check back for the firmware for you.


Quote:
Hi,
We will fix issues with switching to CD all the time. We already did it in some modes, but not all. Please check back for update next week after we complete those changes.



And....? where is atleast any of thos changes ?
Back to top
View user's profile Send private message
zee
Newbie


Joined: 24 May 2009
Posts: 24

PostPosted: Thu Jun 04, 2009 12:37 pm    Post subject: Reply with quote

I have the USB bug as well. It says USB every time pressing next/prev like Stanislav is saying. Sometimes it only happens when switching to CD changer mode.

A handful of my friends on bimerforums are waiting on me to inform how this adapter works as well. I'll be submitting the review to my blog. It seems that new features are being added without fixing existing bugs. There are about 12 days left until I can return my adapter (under 30 days warranty).

I have to admit though the sound quality is great on my Harmon Kardon system. I really wish these bugs can be fixed.

Is there going to be a firmware fix for all of these issues or should I return the adapter and buy an alternative?
Back to top
View user's profile Send private message
Stanislav
Newbie


Joined: 25 May 2009
Posts: 15

PostPosted: Fri Jun 05, 2009 6:24 am    Post subject: Reply with quote

Did more tests today, results:

1) audio volume seems to be fixed on most tracks, but still on some(very few) of them can hear strange "artefacts" in sound.

2) Sometimes adapter keep saying "USB" every time i press next\prev tack, not always but still

And 2 most important problems:
3) usb flash not working sometimes, and after v9 update its worse... spend like 20 mins today trying to get it working...even disconnecting\connecting again adapter to car not working now. And as i said before- its only working with my very old 256mb flash, flash that comes with adapter(256 mb) and "transcend 4GB" not working, tryed different mp3 files with different bitrates, fat16\fat32 etc...

How its looks like ? - i connect flash, it blinks for few times and then it lights constantly, no blinking... on screen it says usualy "1-" for few secs and then 1-1...and not changing...somes times its displaying old tack name (from prev usb flash) but no sound...
When its working correctly (with old 256 mb flash) its blinking all the time)

4) As we said before...adapter keep switching to cd screen all the time.

3-4 is number 1 problems...if you will fix them adapter will be usable...
Back to top
View user's profile Send private message
zee
Newbie


Joined: 24 May 2009
Posts: 24

PostPosted: Fri Jun 05, 2009 9:10 am    Post subject: Reply with quote

I agree the issue with adapter switching to CD or radio modes makes it unusable.

Not being able to fast forward in a track (gets stuck forwarding) also is very annoying.

Is there any other way to skip 10 tracks? It's also annoying having to press next for ~10 times. Before the right dial used to skip to next track but it was fast to skip many of them. But the right dial would conflict with GPS screen. It would be great to keep that feature but ignore right dial when GPS screen/mode is selected.

If above issues are fixed I can keep the adapter and wait more for other issues to be fixed.

Any reason why USB sound was added? It should just be removed.

Making the firmware open source would help with other issues. If not, how about just allowing buttons to be customizable. For example, when CD changer mode is selected I can set what right dial does. I don't see why a mapping file cannot be put next to firmware one and adapter would use it. Just like keyboard mappings in winamp.

As I mentioned I have no issues using different USB thumb drives.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    InDashPC.org Forum Index -> Car integration All times are GMT - 8 Hours
Goto page 1, 2, 3, 4, 5, 6, 7  Next
Page 1 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group