InDashPC.org Forum Index InDashPC.org
In Dash Car PC forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

HOWTO: Build pymedia on Linux
Goto page Previous  1, 2
 
Post new topic   Reply to topic    InDashPC.org Forum Index -> Software
View previous topic :: View next topic  
Author Message
danielrigano



Joined: 21 Feb 2008
Posts: 1

PostPosted: Thu Feb 21, 2008 5:23 am    Post subject: Reply with quote

Thanks for your guide!It helped me a lot.
Back to top
View user's profile Send private message Visit poster's website
wicho_anaya



Joined: 03 Jun 2008
Posts: 3

PostPosted: Tue Jun 03, 2008 2:00 pm    Post subject: I cannot build pymedia in ubuntu 8.04 Reply with quote

Hi, i been trying to build pymedia 1.3.7.3 in Python 2.5 but i get this error:

luis@luis-laptop:~/Documentos/Programas_python/pymedia-1.3.7.3$ python setup.py build
Using UNIX configuration...

OGG : found
VORBIS : found
FAAD : found
MP3LAME : found
VORBISENC : found
ALSA : found
Continue building pymedia ? [Y,n]:y
running build
running build_py
running build_ext
building 'pymedia.audio.acodec' extension
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -DBUILD_NUM=1873 -DPATH_DEV_DSP="/dev/dsp" -DPATH_DEV_MIXER="/dev/mixer" -D_FILE_OFFSET_BITS=64 -DACCEL_DETECT=1 -DHAVE_MMX=1 -DHAVE_LINUX_DVD_STRUCT=1 -DDVD_STRUCT_IN_LINUX_CDROM_H=1 -DCONFIG_VORBIS -DCONFIG_VORBIS -DCONFIG_FAAD -DCONFIG_MP3LAME -DCONFIG_VORBIS -DCONFIG_ALSA -DHAVE_AV_CONFIG_H -DUDF_CACHE=1 -INone -INone -INone -I/usr/include/lame -INone -INone -I/home/luis/Documentos/Programas_python/pymedia-1.3.7.3 -Iaudio/ -I/usr/include/python2.5 -c audio/acodec/acodec.c -o build/temp.linux-i686-2.5/audio/acodec/acodec.o
In file included from audio/acodec/acodec.c:31:
audio/libavcodec/dsputil.h:485: error: declaración static de ‘lrintf’ después de una declaración que no es static
audio/acodec/acodec.c:249: aviso: inicialización desde un tipo de puntero incompatible
audio/acodec/acodec.c: En la función ‘ACodec_Encode’:
audio/acodec/acodec.c:668: aviso: el puntero que apunta en el paso del argumento 2 de ‘avcodec_encode_audio’ difiere en signo
error: command 'gcc' failed with exit status 1

Can you help me please?
Back to top
View user's profile Send private message
Illusion



Joined: 18 Jun 2008
Posts: 1

PostPosted: Wed Jun 18, 2008 7:45 pm    Post subject: Reply with quote

I just tried to build pymedia on my Ubuntu system with gcc4.2 & python2.5 and encountered the same error.

I made one change and have successfully compiled, installed and imported pymedia (I haven't used it yet, but I don't expect this change to affect that).

In <audio/acodec/acodec.c> on line 31 insert the following:

Code:
#define HAVE_LRINTF


So you should have:

Code:
#include <libavcodec/avcodec.h>
#define HAVE_LRINTF
#include "libavcodec/dsputil.h"
#include "version.h"


Note that it must be before including <dsputil.h>

Good luck!
Doug
Back to top
View user's profile Send private message
jbors
Site Admin


Joined: 12 Nov 2004
Posts: 1675

PostPosted: Thu Jun 19, 2008 8:42 am    Post subject: Reply with quote

Yeah another option is to do the saem in config.h Wink
Back to top
View user's profile Send private message
wicho_anaya



Joined: 03 Jun 2008
Posts: 3

PostPosted: Thu Jun 26, 2008 1:45 pm    Post subject: It doesn't works Reply with quote

Hi, i just did what you post and i still have the same error:
luis@luis-laptop:~/Documentos/Programas_python/pymedia-1.3.7.3$ python setup.py build
Using UNIX configuration...

OGG : found
VORBIS : found
FAAD : found
MP3LAME : found
VORBISENC : found
ALSA : found
Continue building pymedia ? [Y,n]:y
running build
running build_py
running build_ext
building 'pymedia.audio.sound' extension
g++ -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions build/temp.linux-i686-2.5/sound/sound.o build/temp.linux-i686-2.5/sound/resample.o build/temp.linux-i686-2.5/sound/fft.o -logg -lvorbis -lfaad -lmp3lame -lvorbisenc -lasound -o build/lib.linux-i686-2.5/pymedia/audio/sound.so
unable to execute g++: No such file or directory
error: command 'g++' failed with exit status 1

Can you help me?
Back to top
View user's profile Send private message
jbors
Site Admin


Joined: 12 Nov 2004
Posts: 1675

PostPosted: Thu Jun 26, 2008 3:16 pm    Post subject: Reply with quote

Not sure what exactly you did but it looks like g++ is not found on your system. Try to run it under account which can run g++...
Back to top
View user's profile Send private message
acidjunk



Joined: 16 Jul 2008
Posts: 1

PostPosted: Wed Jul 16, 2008 4:48 am    Post subject: Installing pymedia on ubuntu 8.0.4 Reply with quote

Hi,

I followed much of the tutorial here and on some other places to get pycar en pymedia installed and working on ubuntu 8.0.4.

Planning to use it with navit and pycar in my car, running on a 1,5 Ghz Pentium Mobile with 2 G Ram, and a 7 inch touch screen (egalax). I got pycar and pymedia working from cvs and same file copies from the iso or windows versions. The problem is that i've very poor performance now; mp3's have artefacts and video's isn't playing at all. (no errors).

I've the same problems also when testing video or music with the pymedia examples as provided.

I read a lot in this forum about a patch for pygame 1.6 (anno 2005). Is this patch still neccessary to run pymedia correct?
Ubuntu comes with pygame1.7.1

I could make a new 2008 tutorial, with all the steps necessary to build and use you cvs versions.

Thanks in advance
Rene
Back to top
View user's profile Send private message
cameron_d



Joined: 30 Jul 2009
Posts: 1

PostPosted: Thu Jul 30, 2009 12:36 pm    Post subject: Reply with quote

Sorry, already solved my problem, I didn't notice the second page...
Back to top
View user's profile Send private message
couzin2000



Joined: 11 Mar 2010
Posts: 1

PostPosted: Thu Mar 11, 2010 5:40 am    Post subject: Reply with quote

Here's what i ran:
Code:
~$ sudo python setup.py install

Using UNIX configuration...

OGG          : found
VORBIS       : found
FAAD         : found
MP3LAME      : found
VORBISENC    : found
ALSA         : found

Continue building pymedia ? [Y,n]:y

running install
running build
running build_py
running build_ext
building 'pymedia.audio.sound' extension
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -DBUILD_NUM=1864 -DPATH_DEV_DSP="/dev/dsp" -DPATH_DEV_MIXER="/dev/mixer" -D_FILE_OFFSET_BITS=64 -DACCEL_DETECT=1 -DHAVE_MMX=1 -DHAVE_LINUX_DVD_STRUCT=1 -DDVD_STRUCT_IN_LINUX_CDROM_H=1 -DCONFIG_VORBIS -DCONFIG_VORBIS -DCONFIG_FAAD -DCONFIG_MP3LAME -DCONFIG_VORBIS -DCONFIG_ALSA -DHAVE_AV_CONFIG_H -DUDF_CACHE=1 -INone -INone -INone -I/usr/include/lame -INone -INone -I/home/sebastien/Apps/pymedia-1.3.7.3 -Isound/ -I/usr/include/python2.6 -c sound/sound.cpp -o build/temp.linux-i686-2.6/sound/sound.o
gcc: error trying to exec 'cc1plus': execvp: No such file or directory
error: command 'gcc' failed with exit status 1
~$

Did I miss a file? In Ubuntu Jaunty I'm not finding a cc1plus package... or do I need to build that too? Help!
Back to top
View user's profile Send private message
MichaelRodriguez



Joined: 18 Apr 2011
Posts: 1

PostPosted: Mon Apr 18, 2011 9:37 am    Post subject: Reply with quote

couzin2000 have you solved the problem? I have the same here...
Back to top
View user's profile Send private message
saramathi



Joined: 12 Sep 2011
Posts: 1

PostPosted: Mon Sep 12, 2011 2:48 pm    Post subject: Reply with quote

I am trying to install pymedia 1.3.7.3on ubuntu 11.04. I am getting the following error. My gcc version is a below:

========================

OGG : found
VORBIS : found
FAAD : found
MP3LAME : found
VORBISENC : found
ALSA : found
Continue building pymedia ? [Y,n]:Y
running build
running build_py
running build_ext
building 'pymedia.muxer' extension
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -DBUILD_NUM=1871 -DPATH_DEV_DSP="/dev/dsp" -DPATH_DEV_MIXER="/dev/mixer" -D_FILE_OFFSET_BITS=64 -DACCEL_DETECT=1 -DHAVE_LINUX_DVD_STRUCT=1 -DDVD_STRUCT_IN_LINUX_CDROM_H=1 -DCONFIG_VORBIS -DCONFIG_VORBIS -DCONFIG_FAAD -DCONFIG_MP3LAME -DCONFIG_VORBIS -DCONFIG_ALSA -DHAVE_AV_CONFIG_H -DUDF_CACHE=1 -INone -INone -INone -I/usr/include/lame -INone -INone -I/home/narayanan/Downloads/pymedia-1.3.7.3 -Ivideo/ -I/usr/include/python2.7 -c video/muxer/demuxer.c -o build/temp.linux-i686-2.7/video/muxer/demuxer.o
In file included from /usr/include/python2.7/Python.h:58:0,
from video/muxer/demuxer.c:27:
/usr/include/python2.7/pyport.h:146:25: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘Py_uintptr_t’
video/libavformat/avformat.h:67:13: warning: ‘av_free_packet’ defined but not used
error: command 'gcc' failed with exit status 1



gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu4)
======================

Any help is greately appreciated
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    InDashPC.org Forum Index -> Software All times are GMT - 8 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group